Erros Emissão NFS-e em Taubaté - SP

Boa tarde.

Erros ao tentar emitir NFS-e em Taubaté - SP.,

[
  {
    "codigo": "X999",
    "descricao": "Erro de Conexão: Erro Interno: 0\r\nErro HTTP: 503\r\nURL: https://taubateabrasf.meumunicipio.digital/servico.asmx\r\n\r\nEndTag: '</' not found\n"
  },
  {
    "codigo": "HTTP 503",
    "descricao": "<!DOCTYPE HTML PUBLIC \"-//W3C//DTD HTML 4.01//EN\"\"http://www.w3.org/TR/html4/strict.dtd\">\r\n<HTML><HEAD><TITLE>Service Unavailable</TITLE>\r\n<META HTTP-EQUIV=\"Content-Type\" Content=\"text/html; charset=us-ascii\"></HEAD>\r\n<BODY><h2>Service Unavailable</h2>\r\n<hr><p>HTTP Error 503. The service is unavailable.</p>\r\n</BODY></HTML>\r\n"
  }
]

ID da nota: nfs_3a127b15d5964dd8a9f6b5969cb6be4e

Aguardo orientações.

Obrigado.

Boa tarde, @luiz.

O webservice da prefeitura está temporariamente indisponível:

Caso o erro persista, favor entrar em contato com o suporte da prefeitura para mais informações.

Boa tarde.

Parece que alteraram os endpoints:

Produção: https://taubate.meumunicipio.online/abrasf/ws/nfs?wsdl

Diferente de https://taubateabrasf.meumunicipio.digital/servico.asmx

Fonte

Aguardo,

@luiz

URLs atualizadas.

Obrigado pela contribuição.

Boa tarde!

Agora, retornou o seguinte erro:

[
  {
    "codigo": "X999",
    "descricao": "Erro de Conexão: SOAP-ENV:Server - Procedure 'ConsultarNfsePorRps' not present"
  },
  {
    "codigo": "HTTP 500",
    "descricao": "<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n<SOAP-ENV:Envelope xmlns:SOAP-ENV=\"http://schemas.xmlsoap.org/soap/envelope/\"><SOAP-ENV:Body><SOAP-ENV:Fault><faultcode>SOAP-ENV:Server</faultcode><faultstring>Procedure 'ConsultarNfsePorRps' not present</faultstring></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>\n"
  }
]

Id nota: nfs_3a128fc9ae6540fc95c41e3fd7fe237a

Aguardo,

Boa tarde!

O pessoal do suporte do sistema da prefeitura, retornaram informando que o XML enviado não está atendendo ao padrão esperado, de acordo com o manual.

Eles sinalizaram na cor laranja, as correções a serem efetuadas.

Considerações:

As tags Numero, DataEmissao e Competencia já foram corrigidos do meu lado.

ID NFS-e: nfs_3a12ae6d5e7f4d44bd3d0e8fe08a055b

Informações para ajudar na resolução:

Link Manual de Integração

GerarNfseEnvio - página 51 do manual.

TomadorServico - página 61 do manual.

Como dito, as tags sinalizadas como “CORRIGIDO” em verde, já foram ajustadas do meu lado.

As demais informações em branco estão corretas, mas foram aqui suprimidas, por conter dados sensíveis do usuário.

Aguardo,

Olá, boa tarde @arimateia !

Por favor, algum retorno sobre esta demanda?

Aguardo.

Boa tarde, @luiz.

Está em nossa fila de suporte. Favor aguardar.

Olá, boa tarde, @arimateia !

Poderia informar qual é o prazo para resolução do caso?

Aguardo,

Boa noite, @luiz.

Finalizamos o ajuste.

Favor tentar novamente.

Bom dia @arimateia !

Fiz nova tentativa.

ID da nota: nfs_3a12c1f324f847a3bd0c22834500238d

Retornou erro:

[
  {
    "codigo": "X999",
    "descricao": "Erro de Conexão: SOAP-ENV:Server - Procedure 'ws:RecepcionarLoteRps' not present"
  },
  {
    "codigo": "HTTP 500",
    "descricao": "<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n<SOAP-ENV:Envelope xmlns:SOAP-ENV=\"http://schemas.xmlsoap.org/soap/envelope/\"><SOAP-ENV:Body><SOAP-ENV:Fault><faultcode>SOAP-ENV:Server</faultcode><faultstring>Procedure 'ws:RecepcionarLoteRps' not present</faultstring></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>\n"
  }
]

Verifiquei que o DPS gerado pela Nuvem Fiscal, ainda não atendeu a tag GerarNfseEnvio, no nó principal do XML.

<GerarNfseEnvio xmlns=".....">
	<Rps>

	...
	...

	</Rps>
</GerarNfseEnvio>

Gerando assim:

image

Aguardo,

@luiz

Feito. Favor tentar novamente.

Olá!

Mesmo problema. A tag GerarNfseEnvio não foi gerada.

ID: nfs_3a12c220c0a14ae3a16452a6e1bb58b2

Aguardo,

@luiz

Sim, foi gerado. É que o endpoint de XML retorna apenas o do RPS.

Enviei uma mensagem privada para você com o envelope SOAP completo. Favor encaminhá-lo ao suporte da prefeitura.

Olá @arimateia !

Suporte da prefeitura retornou:

image

Aguardo,

Olá @arimateia !

Por favor, alguma novidade?

Aguardo,

Boa tarde, @luiz.

Ajuste realizado.

Favor tentar novamente.

Resolvido. Obrigado.