Erro de Conexão

Boa Tarde

Ao realizar o envio de NFS para Paranaguá-PR, esta retornando um erro de conexão, precisaria de auxilio para identificar esse retorno.

{ “DPS” => { “nDPS” => “1”, “serie” => “1” }, “ambiente” => “producao”, “created_at” => “2024-06-11T22:04:04.725Z”, “id” => “nfs_3a1320a79b194b1a8ffda2d4cf49e7ed”, “mensagens” => M->__ValToPrg_Array := Array(1)
M->__ValToPrg_Array[1] := { “codigo” => “X999”, “descricao” => E"Erro de ConexA£o: EndTag: ‘</’ not found\n" }
, “referencia” => “17050”, “status” => “erro” }

Boa noite, @alan.

Iremos analisar.

Favor aguardar.

Bom dia

Algum Retorno?

Bom dia, @alan.

Ainda está em nossa fila de suporte.

Favor aguardar.

Bom dia, @alan.

Tivemos que realizar um ajuste para esse provedor.

Favor tentar novamente agora.

Boa Noite

Validei o retorno e em novo envio, tive essa mensagem do provedor

{ “DPS” => { “nDPS” => “1”, “serie” => “1” }, “ambiente” => “producao”, “created_at” => “2024-06-18T20:39:33.492Z”, “id” => “nfs_3a134466bd74417da5f38d4340059779”, “mensagens” => M->__ValToPrg_Array := Array(1)
M->__ValToPrg_Array[1] := { “codigo” => “00135”, “descricao” => “UsuA¡rio informado nA£o cadastrado como econA´mico.” }
, “referencia” => “17050”, “status” => “erro” }

Pelo que identifiquei do manual do provedor, seria um retorno referente ao login.

image

isso seria uma situação do usuário em si utilizado ou a forma que estamos enviando a informação para o provedor?

Boa noite, @alan.

Creio que seja a situação do usuário em si.

Favor entrar em contato com o suporte da prefeitura para mais informações.

Boa Tarde @arimateia

Em contato com o provedor, me repassaram que esse erro pode ocorrer devido a URL de envio não estar de acordo.

Visto no manual do provedor que o url seria no modelo conforme abaixo:
image

Boa tarde, @alan.

Alteramos a URL para https://paranagua.atende.net/?pg=rest&service=WNERestServiceNFSe.

Favor tentar novamente.

Bom dia @arimateia

Após a alteração, transmissão funcionou, muito obrigado